Bug Tracker

Welcome to the War for the Overworld Bug Tracker! It is our goal to help you get the most out of your copy of War for the Overworld, to that end we try to resolve issues and release patches in a reasonable time frame.


To best help us resolve your issue swiftly please read the following before reporting an issue:


+10
Completed

OSX Crash on startup (After Patch 1.4)

Lostlogic 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 66

Crashes no matter what I do. Even tried turning off graphics switching as per other threads. Also did a validate.


OP Dump.txt

Pending Third Party
Answer

This is working now for me. (It started working before the 1.4.2 patch was released). The only thing that changed, that I can think of, is that I may have had an external monitor plugged in to my MacBook Pro before, and I don't now.

+8
Completed

Heart of Gold lvl 1: Torturing Mandalf does not trigger next stage, level unwinnable

knightenterprises 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 17

Hi, when I torture Mandalf on Heart of Gold level 1, he acts like a normal enemy being tortured. The dialogue that I have seen on other people youtube videos is not trigged. Eventually he is converted to my side, but that is no use to me as the level is now unwinnable.


My specs:

I5 processor

8GB RAM

Windows 7

64 bit

+8
Completed

Units stop acting after prolonged games

wuschelteddy 3 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 44

Hello,


the title says it all. I build a map with the sole purpose to constant fight enemy AI's in prolonged games. After about 45min into the game, when it gets really crowded, the imps just stop working most of the time. Also noticeable is that the units only occasionally attack each other and basically just stareoff mpst of the time.


(I have this every time and basically also on every 4 player map)


Cheers!

+6
Completed

Japanese font was lost

policeofficer110 4 months ago • updated by Cian Noonan (QA Wizard) 4 months ago 6

I made a Japanese translation.
https://steamcommunity.com/sharedfiles/filedetails/?id=817679396

However, in the latest version, Japanese characters are no longer displayed.

OS: Windows 10



+6
Completed

After 1.4.2 update I can not load some saves

adfs sdfa 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 65

After 1.4.2 update I can not load some saves. For example, I can load saves where I played 3-4 hours, but can not load saves where I played 5-6 hours. The game crashes with r6025 - pure virtual function call error after loading almost come to an end. Look on a screenshot. Also I uploaded one of those saves.
1223.png
remote.rar


Answer

Hi all. Hotfix 1.4.2f5 has now been pushed live to the public branch. Publictesting branch is now closed so you'll automatically be moved there if you opt in.


Marking this as complete based on feedback that the issue is fixed in this hotfix :)

+5
Declined

Multiplayer gold

Timothy Gillham 3 years ago • updated by Jan - Eric Merzel 3 years ago 7

Whenever me and my friends host a multiplayer game the host can see his gold and but things and get gold just fine but the people who joined are always at zero gold and their workers wont take gold to their core

+4
Completed

Last mission of regular campaign bug

lolsomes101 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 8

So the last mission of the regular campaign the matriarchs and king are meant to send waves of units at you, however despite a warning saying the matriarchs will send an army to attack you from west side in 10 minutes, they do not come.
Even before this every time the king says he is sending an army to attack, they get stuck at the front door of his base, which then they begin to stack armies each time he sends another army to attack. Thus causing multiple waves of armies to be built up and then attacking, i only got attacked once after 2 waves being stacked, but after defending that he went on about sending more waves, which the AI did this for about 30-40minutes. Not a single unit went through, they just sat behind the door walking aimlessly into it. I could only see 6 dwarfs (after 3ish waves) that were meant to used to dig the dirt (i assume), these also were stuck behind the main gate.

Another bug is that workers would be idle and stuck after building a spirit well and bone chiller. They would kinda moonwalk REALLY slowly in place and be considered idle. Only when i picked them up and moved them to a different area i.e the gold shrine would they begin to work again. That is until they walked into this particular section with the spirit well and bone chiller, then they begin to become idle again. Spirit works aren't affected, but if you have like 11 of the 15 workers idle for no reason then its annoying to pull them out. No impass was placed and there were jobs to be done.

I'll attempt the level again and see if this happens again and see if i can screen shot this. (both incidents)

If needed here is the output log;
output_log.txt

+4
Completed

Witch Doctor Bug

D@rkness 3 years ago • updated by [Dev] Nanorock (Developer) 2 years ago 15

Hi I found a bug with the Witch Doctor. At first the witch doctor functions correctly enhancing creatures in the spirit chamber and going forth and eating and collecting wadges. After about 20-30 min of game play the witch doctor stops functioning correctly. It keeps on casting a green spell of some sort and stops enhancing creatures in the spirit chamber, stops collecting wadges and stops eating and sleeping. In return they always get angry but wont even leave because of the spell the are continuously casting.


Using windows 10 64bit

I7 3610qm Cpu 2.3GHz

16gb ram

Geforce GTX 670m 3gb.


+3
Completed

Missing Polish symbols

Taro94 4 months ago • updated by Lee "Noontide" Moon (Community Manager) 2 months ago 7

Polish symbols are misisng (rectangled X'es appear instead) in 2.0f9, GOG version. They seemed to work in the earlier version (2.0f4).

+3
Declined - Not Fixable

Possible Bug - Lazy Imps

quantum.projects 1 year ago • updated by Cian Noonan (QA Wizard) 1 year ago 8

Hi everyone!



I think the Imps might get bugged with large dungeons, or watery dungeons, or otherwise unknown conditions. As you can see from this Screenshot (see the idle minions report), they idle around traps they should be building, even with the Priority Flag set on the traps.
I have an 8-prop Foundry stuffed with parts, so I know this is not the problem.
The only way to make those Imps work is to drop them inside the Foundry, where they will pick up the parts and bring them to the traps.
However, as soon as they have brought the part they were carrying, they will go idle again, even if the traps are unfinished.
I've tried many things (slapping, summoning new Imps) but it all failed thus far.