0
Completed

New UI GPU performance

w0rdling 8 months ago • updated by Cian Noonan (QA Wizard) 6 months ago 11 1 duplicate

Just updated to 2.0 and the new main menu aswell as the sin menu completely tank performance. FPS are in the low 30s when it was around 100 before. Once in game performance normalizes, unless the aspect unlock menu is opened, in which case performance abruptly degrades again until it is closed.


According to the taskmanager, the "GPU Copy" raises sharply towards the 80% mark while either of the offending menus are opened and returns back to zero as soon as they're closed.


5820k

Radeon R9 390X (current driver, fresh install)

16gb 2400mhz


Edit: Normal pause menu while in game behaves normally.

Edit 2: Here's the output_log.txt

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by w0rdling 6 months ago

Duplicates 1

I just did some further testing and found that opening the controls sub-menu inside the game options reproducibly lowers the FPS into the mid-teens. This then persists, even with the menu closed, until I navigate away from the control sub-menu or close and open the options again (probably because it defaults to the graphics sub-menu).


Here is what my GPU graphs look like by that point: WftO_bug.png

And by comparison with no menus opened: WtfO_non_bug.PNG

+1

I'd like to reply that this is happening to me as well.


Here's my output log: output_log.txt

+1

Hello Guys,
just to give you some background: We updated our UI middleware to a different version for Patch 2.0.

Before 2.0 we had quite some people unable to play the game at all, because this middleware didn't work for them, and now they all can finally play the game.

On the downside this upgrade brought a bunch of new issues, eg. worse performance on some system configurations.

We are working with the Vendor Coherent Labs to find solutions for these issues.

I recon it will take a while to get all these thirdparty issues sorted, but we are trying our best to encourage them to improve on these issues.

Apologies, this appears to be a duplicate of this bug https://brightrockgames.userecho.com/communities/1/topics/3926-new-ui-gpu-performance. I'll post an update there.

+1

Player.log

steam_system_info.txt


I can confirm that this affects me as well, but on Linux. (With the exact same symptoms) Some additional description in this unfortunate dupe post: https://brightrockgames.userecho.com/communities/1/topics/4026-poor-performance-on-linux-after-20-update

+1
Under Review

Hey we are looking into this, we'll get back to you once we know more

+1
Completed - Next Patch

We have pushed some updates and also made a lot of changes internally, please let us know if this is still the case once the next update it live

The situation has somewhat improved after todays patch in that the main menu is now almost asymptomatic and the sin menu appears to be a bit faster aswell. Thank you for that :)


However, the underlying behavior remains the same. Any view with a lot of input fields will still cause, what looks like GPU "thrashing", completely tanking utilization and thus performance. For example the controls menu will still not run above 15fps (no improvement over 2.0), irrespective of graphics settings, including setting the resolution to 1024x768, with the same symptoms as before.

Returning to review queue in light of the customer's response. Please investigate further! :)

Completed

Unfortunately this isn't something that we can pour anymore time into, the root cause is an issue with our UI framework when rendering large windows