0
Declined - Not a Bug

UI Lag

Arturroo 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 1

Hello


OS Windows 10 Pro 64bit

Ram 8Gb

CPU intel I7 5500 2,40 GHZ

GPU gforce 840M

output_log.txt

The game runs fine, but interacting with the main menu and UI in game is very laggy.

I have tried the suggestions in this Knowledgebase article Missing, Invisible or Laggy UI,

I have tried the solution Case 1 and force my nvidia to work witch coherent UI and witch WFTO.

but game works fluently only on -force-d3d9 but the menu doesn't work.


Please help.

Game Version:
Steam Public
Platform:
Windows
Declined - Not a Bug

Hi Arturroo,


I'm really sorry to hear about the issues you're having with the game. It sounds like you're running into issues with Coherent UI, the middleware we use with the UI and my suspicion would be that this is as a result of your graphics card.


Unfortunately your graphics card does not meet the minimum requirements of War for the Overworld if compared on a performance benchmark basis to our benchmark minimum cards (Geforce GTS 450 - 1553 G3D Mark & AMD Radeon 4870 - 1376 G3D Mark) by comparison your card the Geforce 840M only raises a G3D mark of 856 which is well below our minimum requirements.


With this in mind it's very unlikely that anything we suggest would allow the UI to catch up, but we're hoping that some future performance improvements from Coherent themselves could be integrated with the game in the future that may help it run on your system.


I truly apologise that we can't help you further with this and for now my recommendation would be to seek a refund if possible. :(


Best of luck,


Lee