0
Declined - Not Fixable

tearing

membreen 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 11

i get tearing effects with fullscreenmode=on and vsync=on, system: gtx 1060

Game Version:
Steam Public
Platform:
Windows

Please check this thread on how to submit a bug ticket, would be very helpfull and can lead to a faster fix for it

http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/


Screenshot plz.
Output:log
Plz Specs
When does it happen?
What have you done before?

Pending Customer

Hi Membreen, that sounds unusual indeed. I wouldn't expect you to see tearing with vsync turned on.


As Bohser as outlined please can you read the linked topic and provide as much information as possible including your system specs and output log. Can you also use an FPS Meter to record your FPS and let us know what FPS you are seeing in game.

attached a video with the tearing

attached a pic with options


specs:

i7-5820k oc @ 4,3ghz

ram 4x4gb kingston 3ghz oc @ 4ghz

msi gtx 1060 6gb X oc'ed

windows 7 pro 64 bit

monitor asus PB278Q


fps should be 60 because the gpu usage isnt fully loaded


it happens all the time



tearing.mp4

Bizzare, wouldn't expect to see tearing if FPS is locked at native refresh rate. Is there any chance you're running any DVR software, such as Shadowplay? It might be enabled without you knowing.


If not can you submit your outpuit log as well?

output_log.txt


im not running any dvr software


i think the fullscreenmode is bugged, its not a "real fullscreenmode" its more a windowed mode, when i change the resolution in options it just scales down or up with the current desktop resolution in use


when i use a desktop resolution 1920x1080 and start the game with 2560x1440 set in options, the game uses 1920x1080, it does'nt force change the resolution to 2560x1440


in other games with windowmode i get also tearing effects

Very unusual indeed. The Fullscreen mode is provided by Unity so it behaves as they intend, do you see similar issues in other Unity games? What I presume is happening with that is that Unity is not taking control of your monitor as a forced-full screen app might, this allows quick program switching which is often desired by most users.


It's strange that you would get tearing effects in any game that is running in windowed mode, do you see the same result if your desktop resolution is set to 2560x1440 and the game is in full-screen at native resolution?


Are there any particular games where you see this effect occur regularly or does it effect any game that is in "Windowed mode"

Something you could try is forcing the drivers to render the game with Vsync instead.


Via:


  1. Open the Nvidia Control Panel
  2. Navigate to "Manage 3D Settings"
  3. Click the "Program Settings" tab
  4. Add WFTOGame.exe (It should be listed as recent if you recently opened or have it open)
  5. Add Coherent UI - A Modern User Interface Library
  6. Click the dropdown an navigate to WFTOGame.exe
  7. Scroll down the feature list to VSync change the setting to Adaptive or On (Try one and then the other)
  8. Change Tripple Buffering to On
  9. Do the same for Coherent UI

    changes in the Nvidia Control Panel doesnt fix the tearing


    starting the game with a desktop solution 2560x1440 and used the fullscreenmode in game 2560x1440 doesnt fix the tearing


    i tested 3 games...


    lara croft and the temple of osiris... fullscreenmode no tearing ... windowedmode tearing


    mxgp2 ... fullscreenmode no tearing ... windowedmode tearing


    never alone (unity game)... fullscreenmode no tearing ... windowedmode no tearing


    you know, when changing the resolution in fullscreenmode, the display turns off for a second and "restarts" in a the new resolution? this does not happens in war for the overworld. when i do this in never alone it happens.


    Very curious indeed. I believe that confirms my suspicion that Unity is using borderless full screen mode which is a more modern implementation as opposed to exclusive full screen. Essentially in exclusive full screen the game has complete control of your monitor and nothing else is rendered below it, while in borderless fullscreen it behaves somewhat like a window allowing quick tabbing between programs and not disrupting the game in any way.


    Doing a little research leads me to the conclusion that this is a common feature of most up to date unity games (Due to issues in the Unity engine with switching from exclusive fullscreen when in D3D11 rendering.)


    In order to correctly identify why your screen is tearing it'll be good to know what FPS you're getting in the game. I'd recommend downloading fraps for free and just seeing what kind of FPS you are getting in-game, and the same for other affected titles in windowed mode.


    You could also try applying the same VSync options I mentioned above but on a system wide level by changing the global settings in the nvidia control panel.


    The fact that this is occuring across multiple games however suggests that it's unlikely to be limited to our code in which cast there might be little we can do beyond advising of any ideas we might have.



    war for the overworld 2560x1440 fullscreen, vsync=on ... tearing
    2016-10-01 15:23:29 - WFTOGame
    Frames: 13912 - Time: 232769ms - Avg: 59.767 - Min: 42 - Max: 61



    war for the overworld 2560x1440 windowed, vsync=on... tearing
    2016-10-01 15:27:35 - WFTOGame
    Frames: 12384 - Time: 207216ms - Avg: 59.764 - Min: 55 - Max: 61



    mxgp2 2560x1440 fullscreen, vsync=on ... no tearing
    2016-10-01 15:06:36 - MXGP_2X64
    Frames: 4240 - Time: 70715ms - Avg: 59.959 - Min: 58 - Max: 62



    mxgp2 2560x1440 windowed, vsync=on... tearing
    2016-10-01 15:10:21 - MXGP_2X64
    Frames: 3517 - Time: 58641ms - Avg: 59.975 - Min: 58 - Max: 61



    never alone 2560x1440 fullscreen, vsync=on ... no tearing
    2016-10-01 15:14:42 - Never_Alone
    Frames: 5698 - Time: 95379ms - Avg: 59.741 - Min: 48 - Max: 62



    never alone 2560x1440 windowed, vsync=on ... no tearing
    2016-10-01 15:17:44 - Never_Alone
    Frames: 10415 - Time: 173753ms - Avg: 59.941 - Min: 57 - Max: 61

    Declined - Not Fixable

    Hi Membreen,


    Sorry for the late reply, I've been on leave for the last two weeks and have only just got back to the office today.


    I must say at this point I'm rather at a loss for what's happening here, your FPS is consistent and correctly maxes out at 61 FPS. This means that VSync is indeed working and I honestly have no clue why the tearing is happening on your rig. Tearing should only occur when the graphics card is rendering faster than your monitor can display so half the image is displayed and before the next full screen refresh.


    As it stands there's nothing in particular that is jumping out at me and the fact you're experiencing this with other games (but not all) is especially confusing. If this was a problem with WFTO then I would expect it to only present in our game but as it does present in another game I can only conclude that there must be something else happening on your computer that we're not aware of whether that be a mechanic of your graphics card or monitor or perhaps some other program interacting unusually with the games.


    Unfortunately the only solution we might have been able to work in on our side (Which is having the game control your monitor in an exclusive full screen mode. However this mode is not well supported by the Unity Engine and we can't provide it as an additional option on top of the default mode. As it stands we have no way to help you further with this issue and I can only apologise and hope that you manage to find a solution to the issue.


    Best of luck and sorry that we cannot assist you further in this matter. At the very least I can say that if Unity ever extends support for display modes we may be able to utilise that to fix your issue in the future.


    Cheers,


    Lee