System Requirements

Below you can find the System Requirements for War for the Overworld. We have divided our system requirements into Three Major Categories, please note that these specifications are guidelines only and do not factor in unique differences between systems.

Our Specs Explained

  • Minimum - The Minimum spec of a computer on which War for the Overworld will run. Players are liable to experience issues with War for the Overworld and may experience crashes, significant frame drops or other undesirable experiences.
  • Recommended - Computers that meet this spec should be able to play the game from start to finish with few if any issues. Performance may be impacted under certain gameplay conditions and FPS in strenuous conditions may drop below 30FPS. Some adjustment of graphics settings may be required.
  • Optimum - A High-end specification that should be able to achieve stable FPS even at the highest graphics settings. Particularly strenuous scenes may cause the frame-rate to drop below 60FPS on 1440p displays.

Understanding G3DMark

In order to clarify the exact requirements on Graphics devices, we have included an example G3DMark results for a graphics card that meets the spec requirements.

G3DMark is a benchmark present in PassMark Software and is a reference for how a graphics card performs against other cards. Higher is better.

You can find a full list of G3DMark results at VideoCardBenchmark.net. You can also compare your results to ours by downloading Passmark's PerformanceTest 9. They have a 30-day free trial you can take advantage of, it is a one-off payment of $27.00 once the trial has expired if you wish to continue using it. 

Intel Cards

We do not include Intel graphics devices in any of our specs as we do not officially support them. However, we are aware that the game runs on the vast majority of Intel devices. It is recommended that iGPU players only buy WFTO if they are prepared to refund it in the case of severe instability.

If you have an Intel card and are having issues with the game on Windows we advise you to try running the game in D3D9 mode as described in this article.

Intel Iris Macbook Pros (2017 Onwards)

Unfortunately due to an incompatibility between the latest Macbook Pros and the rendering pipeline of the version of Unity which WFTO is built upon, Macbook Pros with Intel Iris graphics built from 2017 onwards are not supported.

2017 and onward Macbook Pros which feature Intel Iris graphics suffer from severe instability which causes graphics rendering in certain unity games to stutter and render images out of order. We are unsure of the exact cause of this issue but it is presumed an incompatibility between the latest Intel Iris graphics chips/drivers and Unity's rendering pipeline is at fault. It is also possible Apple's ongoing depreciation of the OpenGL API in favour of the proprietary "Metal" API is at fault as Unity uses OpenGL to render graphics on OS X based systems.

Sadly, as we cannot control these factors, there is no support that we can offer beyond advising users ensure their drivers and Operating System are up to date in-case Intel or Apple have deployed a fix. We will continue to monitor for fixes from Unity however as WFTO is running on an older version of the Unity engine it is unlikely we will be able to deploy a fix safely should one be delivered.

We offer our sincerest apologies to our fans who are affected by this issue.

War for the Overworld - System Requirements


MINIMUM:


  • OS: Windows 7 SP1, Windows 8, Windows 10, macOS 10.10 or Higher, Ubuntu 12.04 or higher
  • Processor: Dual Core CPU @ 2.5GHz
  • Memory: 4 GB RAM
  • Graphics: Nvidia GT450 series with 512MB RAM or better, ATI 4870HD with 512MB RAM or better
    • Minimum G3D Mark: 1500
  • Hard Drive: 7 GB available space (may increase in the future)
  • Sound: Speakers or headphones


RECOMMENDED:

  • OS: Windows 7 SP1 (64-bit), Windows 8 (64-bit), Windows 10 (64-bit), macOS 10.10 or Higher, Ubuntu 12.04 or higher
  • Processor: Quad Core CPU @ 2.5GHz
  • Memory: 8 GB RAM
  • Graphics: Nvidia GTX 560 series with 1GB RAM or better, Radeon 8950 HD with 1GB RAM or better
    • Minimum G3D Mark: 3000
  • Hard Drive: 10 GB available space (may increase in the future)
  • Sound: Speakers or headphones

OPTIMUM:

  • OS: Windows 7 SP1 (64-bit), Windows 8 (64-bit), Windows 10 (64-bit), macOS 10.10 or Higher, Ubuntu 12.04 or higher
  • Processor: Quad Core CPU @ 3.0GHz
  • Memory: 12 GB RAM
  • Graphics: Nvidia GTX 770 series with 2GB RAM or better, Radeon R9 380X with 2GB RAM or better
    • Minimum G3D Mark: 6000
  • Hard Drive: 10 GB available space (may increase in the future)
  • Sound: Speakers or headphones
Linux Notes:

There are the following additional requirements:

  • glibc 2.14 or later
  • libstdc++6 or later
  • GCC 4.9 or later
  • Only 64 architectures are supported on Linux.
  • Only the latest video card drivers are supported.
  • OpenGL 3.0 support is required.

This article was helpful for 6 people. Is this article helpful for you?