General Help and Support

Welcome to the Brightrock Games Help & Support service. It is our goal as a developer to maintain a strong connection to our community through regular open communication.

Through our User Echo service we aim to provide an easy method to contact us and provide feedback directly. Please note if you would like to report a bug with War for the Overworld please head on over to our WFTO Bug Tracker.

Here you can submit public or private support tickets directly to us regarding our other services such as:

  • Our Community Forums
  • Our Discord Server
  • This User Echo Service

You can also submit feedback and complaints directly to us. We'd love to hear what you think about us!

Not a bug

Severe lag in last level of heart of gold

Ossorus 2 years ago in General Feedback • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 2

Hi all,

Playing the last level of the heart of gold expansion and i simply had to just quite because the lag is too severe. I have a gaming laptop so don't think the issue is my hardware. Is this a known issue and is there any suggested fix/ETA for patch to fix?

Pending Customer

War for the Overworld crashes after splash screen (fixes providied don't work)

FennyBenny 3 weeks ago • updated by Cian Noonan (QA Analyst) 3 weeks ago 1

Whenever I start the game, the splash screen appears like normal (WFTO.exe starts), then goes away, and WFTOGame.exe starts. The game crashes before a black screen. I don't own a wire-less headset, so that mustn't be the issue.

Not a bug

Security - Password - "This connection is not secure"

Kwintus5 12 months ago in User Echo • updated by Lee "Noontide" Moon (Community Manager) 12 months ago 1

Hey All,

I noticed that when I wanted to change my User Echo password (profile => security) that I get the error you can see in attachment. It roughly says "This connection is not secure. Login-information inserted in here can be intercepted."

I don't think that's intended? I heard it could be that my flash player is not up to date, so to be sure I updated it to the latest version, but I still get this warning.

Just saying. :)

Unsecure connection User Echo.JPG

Kind regards!



Dedicated graphics card requirement?

lukelehane 1 year ago in Community Forum • updated by Alexpaul 2 months ago 2

HI all,

I bought a new laptop recently, installed WFTO and couldn't click anything/dig etc.. I had a look online and it seems like this is a common problem caused by integrated Intel cards. I used to play this game on another laptop that also had an integrated card, is this a recent development? Is there any plans to iron out whatever is causing this for us integrated card people? It seems a shame, as, frame-rate wise, the game seems to be running fine.

I miss this game!

Thanks very much,



How can I obtain a DRM-free version?

n3ph 1 year ago in Kickstarter • updated 1 year ago 4


I am an early adopter and purchased via Kickstarter looong time ago... How do I obtain a DRM-free Version via Humble?


Please add an autosave or quicksave

Omega79 1 year ago • updated by Cian Noonan (QA Analyst) 8 months ago 2

Just waht the header says ;)

guess its a minor thing to code in .... but just guessing ;)


This feature is now in the game ;)


Is the achievement Prison Architect impossible in WFTO?

hennaromp 1 year ago • updated by Lee "Noontide" Moon (Community Manager) 1 year ago 4

I've tried to do the level 6 under 15 minutes but it seems impossible. I haven't figured out how to free all the minions under 15 minutes, or how to kill the level 8-10 enemies with the ones I've freed at the time. Has anyone done it after the updates? Is it even possible to do now?


Locked out of discord

Webbernever1 1 year ago in Discord • updated 1 year ago 2

Around a month ago, I made a discord account. However, I have been having trouble with it since I started, and it has now decided to lock me out entirely.

A week after making the account, the discord insisted that I was logging in from another location (Hertfordshire), even though I am using exactly the same computer in exactly the same room. I nonetheless verified this new 'location' and it let me in. I changed my password after so doing. A few days later it insisted that I had changed location again, this time Luton. Again, I verified the account, it let me in, and I changed my password. A few days after that, it said that I was in Luton again, and I had to verify it again. I changed my password yet again.

However, a few days ago, it insisted that I had changed location again. This time, no e-mail was sent to my e-mail address. Thus, I am not able to verify my supposed new location. At NO point have I switched location, and I neither live in Hertfordshire nor Luton.

What I want to know is:

1 - Why it keeps insisting that I have switched locations? I presume that this is not normal.

2 - How I can stop this, if it is possible.

3 - What to do about being locked out.


Question About Game Resolution

IamDoom1337 1 year ago in Misc • updated by Hoskinmage 1 year ago 5


I have a question regarding the in-game resolution for War for the Overworld. Is it possible that I can set an internal resolution (not the resolution of the game itself in the options) to the resolution of my old computer (1336x768), while the external resolution is the resolution of my newer computer (1920x1080)? I only ask because I noticed that the game will begin to not run as smoothly as it would if I put the game in my current computer's native resolution. If I put it to the resolution of my older computer, it would run better, albeit with blurry-ish textures. It also doesn't fix it if I put the texture option (unfortunately I don't remember what it is called) to 100%. If there is a way to do this, or if that is not possible, let me know at your convenience. Thank you!
- Alex


Using Mouse Scroll Wheel in Map Editor

MajHerbHead 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 1

Hi everyone

Just an idea from myself, I will try to explain best I can.

I have started to use the Map Editor now and have a small request/suggestion.

Best example - Once I have placed a minion, to change its level I right click on it, Left Click in the Level Window - Now all thats fine, its this next bit thats slightly annoying - I personally like to use the Scroll Whell on my mouse to navigate up and down menu's, only thing is when I do it here the view in game zooms in and out accordingly as I scroll down to select a higher level the camera zooms out, its also the same the other way around.