0
Completed

Import map does not work

Галиев Рустем 3 years ago • updated by Terrarkul 3 years ago 18

Windows 8.1 64 bit, 8 Gm RAM, Intel(R) Core(TM) I7-4500 CPU1.80 GHz 2.40 GHz GPU: AMD Radeon R7 M265, Intel(R) HD Graphics Family. Version game fresh, 1.3.1f5

I go into the map editor, choose "import" in all three tabs - empty. Please fix it.

output_log.txt.

War for the Overworld Launcher Log.txt



Game Version:
Steam Public
Platform:
Windows
Under Review

Took a quick look at the Output log, looks like one (or more) of the workshop maps downloaded has thrown an exception due to missing/corrupted meta file

"

Loading meta C:\Program Files (x86)\Steam\steamapps\workshop\content\230190\586262676\Prima Cairos Custom Campaign_76561198037862594.meta failed
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebug.gen.cpp Line: 56)

DirectoryNotFoundException: Could not find a part of the path "C:\Program Files (x86)\Steam\steamapps\common\War For The Overworld\WFTOGame_Data\uiresources\maps\prima cairos: (custom campaign).76561198037862594.unity.png".
  at System.IO.FileStream..ctor (System.String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, Boolean anonymous, FileOptions options) [0x00000] in <filename unknown>:0 

The map Prima Cairos seems to be causing the issues, try unsubscribing from it then re-verifying your steam cache, see if that fixes it by removing the problem map.

In the mean time i'll ask one of the coders to take a look at your log, they'll understand the meaning of the error better than I do.


I did as you advised.

1. Removed map Prima Cairos.

2. Checked the integrity of game cache.


It did not help - the import map is empty.

That suggests the map hasn't been correctly removed (not your fault, it'll be a problem on our end), I guess we'll have to wait for a coder to check the log and see what they suggest.

I applied a quickfix which will allow to view importable maps again.
However this is just fixing the symptoms and not the root cause.
I am waiting for a mate who is away between the years to figure how this case can even happen as it shouldn't.

Not matter what the issue will be resolved for you with next update.

It appears this is linked to another issue where maps with a colon in their name (a : ) aren't saved properly so are causing exceptions when your lobby tries to load their data.

I checked - I have no cards (created by me, or subscriptions) with a colon (:) in the title.

I have no maps*, amendment.

Completed

flaggin as fixed, please report back if the issue still persists in the next patch :)

Today released a new patch is good. I played after installation. The map editor appeared imports - official maps can be imported. But maps of the workshop manager that I created, "Import" button gray, pressing her to anything not lead, that is, you can not import them.

The only problem with maps that I created.
Reports of the game.

Hey why did you posted this twice, like here and there http://brightrockgames.userecho.com/topic/1077824-do-not-update-the-map-display-in-the-workshop/ ?

From the screen shot this looks correct.
You need to select a map from the list first, only then the "Import" button turns from gray to white.
(Because otherwise it wouldn't know which map to import)
This should not depend on the map.
If the button becomes white for any selected map in any tab it will turn to white for every map.

Or did I misread/misinterpret what you said?

    I do not understand how you can not understand a simple thing. Maps that I created. They can not be imported. That button is gray - this is not the problem. This is a reflection of the problem.
Can not you see that I have selected a map? What, in your opinion, is displayed on the right, on the screenshot?

    PS Repeated in another topic post is wrong.

Sorry I had a bit issues to understand the english.

Well in the screen shot there is a map preview image shown on the right side but no map in the list is highlighted (brighter text + brighter border) to show it is selected.
I thought you were reporting that the "Import" button does not turn white when you select a workshop map.
(Which made no sense to me, because the UI does not make a difference about which map selected and it should not matter which one you select, the button should always turn to white after selecting a map)

So what is the exact Problem?

You select the map you want to import from the list, it is highlighted and the "Import" button is white, but then you click on it but nothing happens?






I just tested creating a map, publishing it to steam and importing it and it worked fine for me at least.

I just switched my game to russian language and tried it again and it worked.
See:
https://imgur.com/aRclUmS

In this screenshot my work shop map "Sorry Test can be removed" is correctly highlighted.
The text is white and has a white border, unlike in your screenshot.

Again I entered the game. And now my maps available for import. Thank you.

P. S. the Problem before was, that you can see on screenshot, and I have several times clicked on their maps, others the result was different.


Ohhh then I guess it was actually an issue with the import UI and not the import function.
I was wondering because it should not be possible that there is a map preview on the right side while no map is actually highlighted in the list, but this was happening in your screen shot.

I am glad that it works now for you! :)

I have found a similar importing issue; I cannot import maps that I have created and published from the workshop. This would be fine if I had any other way to load up one of my finished maps after clearing their saves from my in-progress maps list.