0
Completed

Crash on completed loading screen

lolsomes101 2 years ago • updated by Raz Keltsh 2 years ago 8

Splash and loading screen come up fine, once the bar is fully loaded, before main title screen game crashes. No error pop ups. Game worked fine from first purchase (29May) till last night. Unless there was a patch done between when i last played 3am June 1 (AEST) - 4pm June 2 (AEST), its causing a crash.
Have tested all workaround stated in forums. Verified steam cache is fine, .NET framework is up to date, AVG is off, no wireless headphone is used (if so i have a wired headset which i also unplugged in an attempt to see if that matters.), no mods have been installed
No crash log can be found. Unless its not called Crash_log or something along those lines.
OS: Windows 7 64bit
CPU: Intel Core i5-3330
GPU: NVIDIA Geforce GTX650
RAM: 4gB
Latest working build: 1.4.0f7 (from the updates page, game is set to auto-update)
output_log.txt


Game Version:
Steam Public
Platform:
Windows

Answer

+1
Answer

No need to be sorry, i just stated everything i tried to make things easier to solve the problem for you guys!

So many complex solutions and the easiest solution was steam. Somehow it bugged itself despite being online and restarting it, it did not initialize the game as Scott said.

Thanks for the quick reply gents! Everything is running smoothly

Pending Customer

im sorry to ask since you stated you tried everything but did you also try adding :


-force-d3-d9

as a launch setting under the games properties?


if you did and this did not help you i will send your output log to the coders.

Hi. According to the log, it looks like Steam has failed to initialize when starting the game. Make sure you're not in offline mode and that steam is logged in and running.


InvalidOperationException: Steamworks is not initialized.
+1
Answer

No need to be sorry, i just stated everything i tried to make things easier to solve the problem for you guys!

So many complex solutions and the easiest solution was steam. Somehow it bugged itself despite being online and restarting it, it did not initialize the game as Scott said.

Thanks for the quick reply gents! Everything is running smoothly

Normally the game was supposed to show a dialogue informing about this or any other starting problem.
However it did not work and it simply quit the game before there was a chance to look at the dialogue.
This is now fixed and when any loading error occurs the game will now correctly show a dialogue
and only quits the game after the "OK" button was clicked.

Your report helped us to find this little flaw :)

Hi I am experiencing this when loading into a campaign mission CTD.jpg

Hi Raz,


Looks like the issue you're experiencing is related to this: Crash when loading a save / loading certain skirmish maps / map editor maps (Patch 1.4.2) Please give the workaround a try and let us know how you get on.


Cheers,


Lee

Thanks Lee, yeah rolling back to the previous version in steam properties > betas solved the issue.