0
Declined

No Menu UI

wraiith777 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 13

I've come back after playing during the beta.


No menu, just the dungeon heart and music after loading screen.

I've set the game + ui to run on my gfx card, tried both dx options, tried opengl, tried administrator, updated drivers etc


output_log.txt


I've waited onscreen for 10min+ just to make sure the menu load isnt delayed.


Core i7

Nvidia GFX card

4GB RAM

Win 8.1 x64


Just purchased the collectors edition upgrade yesterday - without launching game first i know :(

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by wraiith777 2 years ago
Under Review

Thanks for taking the time to look into the problem yourself and try known solutions already. I can see the issue in the log - Our UI subsystem isn't correctly running on the Nvidia GPU. I have pasted and highlighted the important part of the FAQ instructions that should help you resolve this:


  1. Open Nvidia control panel
  2. Select 3D Settings and reset your settings to default
  3. Select "Program Settings" tab from the 3D Settings menu
  4. Add WFTOGame.exe from your WFTO Directory (You can find this by rightcliking the game in steam, going to properties and clicking "Browse local files")
  5. In addition be sure to add "CoherentUI_Host.exe" with the same settings below.
  6. Select "High-performance Nvidia Processor" as the preferred graphic processor as above.

Please do let us know if this does not resolve it for you.

+1

Hey, did as you asked, still same issue.


Reset all settings to default, and set WFTOGame.exe & CoherentUI_Host.exe as High Performance GPU.

Waited another 10min in menu screen just in case it was a delayed load.

settings.png

output_log.txt

Accepted

Thanks for the solid follow up. That is strange. We've contacted our UI subsystem partner to help us resolve this issue for you.


I'll keep you psoted on updates and my apologies for the inconveinience caused here.

Just following up, with the new patch the issue still persists.

That really sucks. Could you please attach the latest output_log file? Cheers

I know you said you tried this earlier, but could you please try the following and then give me the output_log again once you've run the game:

  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add the following in this box:
-force-d3d9

Apologies for the continued issues here. I'll be honest - We're not sure what further help we can render at this point. This issue you're having has been solved for all of our users with the steps identified in the FAQ - Primarily the steps where you get your GPU drivers to run the game and the UI system on the powerful GPU.


As you said in your initial post, you've tried all of this to no avail. All I can suggest at this point is your triple-check those steps. We will be updating the UI system in a month or so to a new version. It may help, or it may not.


It upsets us to say this, as we really want you to experience the game, but at this point it may be in your best interest to refund the game through Steam and get your money back. I say this because I don't want you wasting your money on a game that may not work for you when the update comes out.

Hello!

I've just bought WFTO, download + install and... there is no menu for me.

I did everything what is said in this thread: https://forum.subterraneangames.com/threads/solution-for-ui-does-not-show-or-game-is-very-slow.8665/

So I change my Intel to AMD as high performance but there is still no menu for me - just the dungeon heart + all sounds. It's changed to "High Performance" even after PC restart.

Clipboard01.jpg

By watching movies on YT I've found invisible (for now) Campaning button and manage to start game but it stops to work after few seconds.


My PC:

Windows 7 Home Premium 64-bit

Intel(R) Core(TM) i5-5200U, 2.20 GHz (4 CPUs)
8 GB RAM
Intel(R) HG Graphics 5500


Here's the latest output

output_log.txt

Hello Kamil,
Can you try to assign coherentui_host.exe (in your screenshot) to a GPU as well.
While your Intel CPU is weaker it can make sense to have the UI Host on a separate GPU to share work between them, but I don't know what dedicated GPU you have installed and maybe it work better if both run on the "High performance" GPU.
Thus can you try both and see if either makes it work for you?

Cheers

Hello

It's already on high performance, both wtfogame.exe and coherentui_host.exe

And game is still not working... I also can see that according to what is written in output_log.txt my PC is still using INTEL instead of AMD. But once again - how to switch it? :|


Scott Richmond moved my thread here: http://brightrockgames.userecho.com/topics/1064-game-runs-with-no-gui/#comment-4181

Declined

Since the original report was moved, I decline this one.
For further input please follow the link one post above.