0
Completed

RHOAD: Broken summoning stones

Azeo 2 years ago • updated 2 years ago 7

Hey so firstly the update is awesome and was so well timed with my random desire to start playing again(literally a few hours before you updated). Your update fixed my game crashing all the time( it crashed once now and the announcer shortly before crashing told me to save regularly) Though I'm still getting random lag spikes every 5 or so seconds for about a second or so and it would affect the game. eg. dragging rooms/digging or placing things which are sometimes misplaced and inhibits my mana use spam during overload.

I've spent hours and hours on each level and about 9.5 + another 1.5 hours on level 2 until upon reloading the game all the summoning stone artifacts are now unidentified and cannot be identified even after unclaiming the room, I can click on them visually and they disappear with nothing happening in-game apart from the artifact disappearing visually onscreen (they stay in the UI). Now forced into restarting the level and having a broken near 10 hour save I was well into the next level with dungeon built nicely and going for the optional undetected approach I accidentally got detected when dropping an imp that I thought was out of site, so I reloaded 13 minutes back and now the save is also broken. Same error where the artifacts are worthless broken annoyances and now need a 3rd new game.


Also I can no longer prequeue the next ritual whilst the one I just cast is being used and also on cooldown. Plus prior to the errors when I was able to prequeue; if I were to cast avarice and whilst the spell is being used go to select the next ritual but misclick and then press X to unselect and reslect it also cancels the current spells process immediately.


Sad to see my AFKable self sustaining human farming dungeon is now utterly uncompletable.

The only thing I've done between that save and playing when it was unbroken was update my GFX drivers; attempting to fix the lag spikes. Could this have been the catalyst for this bugs occurance? Note: I've reverted to my old drivers and the problem persists.
I do really wanna keep playing and not shelf the game for months like I did when it used to randomly lose the UI and crash.


I linked some screenshots of me before and after clicking them, pretty much straight away after and nothing happening whatsoever.

1st game v





2nd game v





Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Azeo 2 years ago
Accepted

This looks to be a save/load issue, with the state of identified artefacts not being saved correctly.


Whilst you're waiting on a fix, I believe if the artefact has been identified and used, before saving (or all remaining artefacts or either unidentified or used/activated) it should save and reload ok, it's only the actual saved state of the artefacts which doesn't have correctly.


Hope that helps you get through it, thanks for the report.

Yeah thanks for the quick response, I've replayed and finished the level and saved just before clicking the last stone, had a little break to hear the home world quotes and did some things came back and it crashed once trying to load to test. 2016-05-31_040240.7z
Anyway once I got into game it was broken again and I wouldn't have been able to finish. Is this an error on my end, something I can try?

Also while I'm here maybe I should mention: In the homeworld the announcer refers to "Kasita" verbally and in subtitles, though ingame tooltips say "Underlord Oberon". Is that right?
Plus on either normal or HoG homeworld I seem to get super lag like freeze frames when the path is blocked to downed bodies and/ or gold, specifically midas door in this case or also if the blade lotus is up in defensive mode. So if its inactive and the door is open there is zero lag, it lags if I close the door and stops when I open it upon clicks.

SS of aforementioned enclosure that causes lag once pathing is blocked and tooltip oddity.




Thanks for your help and also thanks to all parties involved in this great game of epic wickedness!

PS: Also keen to again be able to pick up my Sir Roussimoff or new ones :p

The Oberon issue in homerealm has been reported, this should be fixed soon.


im unsure how to understand your porst , did you get stuck on the mission again?

we are investigating the cause of this and you will sadly either need to wait for a fix (i will prioritise it higher)

or play the mission without saving the game, if you crash regulary (which is bad in itself) then this may not be a possibility. Im truly sorry for the inconvenience!

Hello = ) And thanks for the report ! So I fixed internally, hopefully it should get live quite soon. But it can only recover one save, meaning if you loaded a save game and then saved it, this won't fix it I'm afraid, as some data get lost on reload in the current public state.

Thanks a lot. I haven't saved over any games that originated prior to the error. I'm on level 4 now <3