0
Declined

After updating, game is now crashing during boot up

Justin 3 years ago • updated by Jan - Eric Merzel 3 years ago 4

Hi,


Love the game - thanks so much for doing it!


I haven't play WFTO for a couple of months and decided to play again. There was a brief auto-update after I'd launched Steam, then I hit the 'Play' button to launch the game through Steam. It never got past the initial load up however.

After around a minute of hanging on the initial loading screen (attached 'WFTO_InitialLoadingScreen_Crash'), the screen went black and crashed out to the mac desktop.

Reproducibility is 100%.


FYI I think it's the Public Beta Game Version, but can't see the main menu so can't be sure.


Flow:

1. Launch Steam

2. Navigate to WFTO game page

3. Hit 'Play'

4. Black screen appears for ~20 seconds

5. Loading screen appears for ~40 seconds ('WFTO_InitialLoadingScreen_Crash'')

6. Black screen appears for ~10 seconds

7. Game crashes out


Specify your platform:

OS = Mac

Version = Yosemite 10.10.5

PC3-10600 DDR3 1333 MHz type RAM

Memory = 4GB

Full system details are in the 'Problem_Report_for_WFTO" log attached.


Various logs and screenshot:

WFTO_InitialLoadingScreen_Crash

Player.log

Problem_Report_for_WFTO.txt


Thanks,

J

Game Version:
Steam Public Beta
Platform:
OS X

Hello Justin,
your log says that there is an issue with loading some libraries from the mono runtime.
This is strange, because recent patches should not have changed anything on this matter.

Later the game crashes when trying to access existing steam workshop items.
So not our code crashes but the steam workshop API and I do not know why yet.

Just to be sure its not a standard startup crash:
Do you use any speakers or headphones connected via USB while playing?
If yes, please unplug it and try if the game starts. If this is the cause, make sure it is set as default audio device and setup as stereo (not mono) device, before starting the game while plugged.

Thanks for the quick response.

I had headphones plugged into the stereo jack but not USB.


You are right about Steam - after reading your response, I updated my Steam client and the game launches fine now :)


Thanks!

Justin

I am glad to hear the issue was resolved that easy.
Have fun playing again! :)