0
Completed

Bug placing room tiles

Blink 4 months ago • updated by Lee "Noontide" Moon (Community Manager) 2 months ago 10

I have had this several times since the last update...

When placing a room, for example this 5x5 hatchery, it looks like only some tiles are placed and the room isn't complete:

War for the Overworld 
A Screenshot of War for the Overworld
By: Blink



If you hover over the room it says its too small:

War for the Overworld 
A Screenshot of War for the Overworld
By: Blink



But if you try to place room in the missing squares, you can't:

War for the Overworld 
A Screenshot of War for the Overworld
By: Blink



If you save your level, close and reopen you see you do actually have a full 5xr5 room.

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Could we get a log please.


Posting Output Logs

output_log.txt


Here is the log from my last game play. I believe it happened in this session, but not 100% sure.


I'll also add another log the next time it happens.


Blink

FYI - If your trying to track this down by hand, rather than the logs - I'm trying to remember the circumstances when this definitely happened:


- playing levels in the the custom campaign "My Pet Dungeon - classic DK2 campaign" certainly (I can''t be sure if I've had it with other levels)

- creating a hatchery (I think I've also had it with vault)

- select a 55x5 area to dig out - then select hatchery and reselect that area (with no other minion activity) - wait till the blocks are cleared and the floor put down - then immediately release to put down the room tiles. (i sure it has always happened when quickly placing a room in newly dug areas)


It feels like the could be some lag between the tile being visually cleared and floored -  and what the program actually thinks is cleared and floored. - just a possibility.

I were able to reproduce it in MPD Custom
It seems only the slaughter pen is beeing effected by that (as far as I noticed)

output_log - Kopie.txt



MPD Campaign:
https://steamcommunity.com/app/230190/discussions/0/1694919808741069693/

It's not just the Slaughterpen - I've had the exact same thing happen with the Lair and Library as well.


I've also noticed that the fortified walls aren't all changing to match the room - you can see this in Biervampir's picture above with some of the fortified walls around the Slaughterpen and Lair.


I was only playing MPD when this happened (haven't tried on other game modes yet), and so as time wasn't much of a factor I was able to get around the problem when creating other rooms by placing them one tile at a time, rather than click-and-dragging to place the entire room at once.

It does happen for any room at the same location.

We identified the issue is caused by importing very old maps and increasing the amount of players.

In this case setting the walkabilities for each faction on some blocks cause errors, because the blocks only provide slots for the faction count from the older imported map.


We implemented now a fix for this which makes sure exported maps have walkability slots for all newly added factions.


All you need to do after next Update is released:

- Load your map in map editor, and export/publish it again.

This will fix the issue after next Patch is released.

Hope this helps!


+1
Completed - Next Patch