The prop position bug

Webbernever1 7 months ago • updated by Cian Noonan (QA Analyst) 4 months ago 9

Operating System
    Windows 10 Home 64-bit
    Intel Core i7 6700HQ @ 2.60GHz    45 °C
    Skylake 14nm Technology
    32.0GB Dual-Channel Unknown @ 1196MHz (17-17-17-39)
    Alienware 0FG0DK (U3E1)
    Generic PnP Monitor (1920x1080@60Hz)
    Intel HD Graphics 530 (Dell)
    NVIDIA GeForce GTX 1070 (Dell)    46 °C
    ForceWare version: 378.66
    SLI Disabled
    931GB Hitachi HGST HTS721010A9E630 (SATA)    36 °C
Optical Drives
    No optical disk drives detected
    Realtek Audio

In short: I can do this:

As you can see, the props are displaced. This bug is Very easy to replicate, but only seems to occur 90% of the time. This is done in the map editor.

Step 1: Build a 3x4 room with a prop in it. Can be larger, but this is easier to demonstrate.

Step 2: Place Any room next to the prop.

Step 3: The prop shall stay there, even if reloading And when playing:

Any room is capable of doing this. The room does not have to be 3x4 but a prop must be next to the space where you place the room. For some reason, this does not occur 100% of the time, but it occurs more often than not.

Additional information:

* Saving and reloading does not fix the bug.

* Nor does rebooting the game.

This requires you to place cover all adjacent tiles. For instance:

This works:

So does this, for some reason (only two out of three covered):

This does not (covering just one tile is not enough):

Can be replicated very easily, but here is my output log anyway:


Game Version:
Steam Public

I think I can see the issue, I'll pass this straight to the code team

Could it be possible, that the same, or at least a similar bug, causes those weird room props in MP as well?

Not sure if it is related but here is a prop bug I encountered midgame in version 1.6.4:

Output log (as a client):


Found a new variant of the prop bug:

In the map editor, start off with a room

Next starting building a room on top of it:

Complete all but one tile:

Now place the last tile:

This stays glitched even in skirmish mode.

Here is a map I used to create it:

garrison test_76561198271056091

garrison test_76561198271056091.meta

Here is a save file:

garrison test_20171109153553

garrison test_20171109153553.meta

Output logs:



Multiplayer prop bug happened again.

Client output log:


Completed - Next Patch