0
Completed

Performance issues, unable to identify the cause

Menta 1 year ago • updated by Cian Noonan (QA Wizard) 1 year ago 3

Entering the main menu is a world of pain. Audio slows down to a choppy mess and the mouse hangs horribly. Checking my task mgr I notice huge CPU spikes. When I enter the options from the menu, the game runs perfectly. When there's a video playing, the game also runs great. When actually ingame, Ill have the performance issue return every minute or so. With periods of high fps in between. I'm truly mystified by this issue, and have tried a few things to fix it.

Interesting to note is that when I alt-tab out of the game, it runs fine. Since I can hear the audio in the background running fine, not choppy at all. I cant shake the feeling it is coming from the menu system.

Ill start with my specs:

Intel i5 2500k OC'd to 4ghz
Asrock P67 Extreme
8GB DDR3 1600mhz 
Gtx960

I realize the CPU is getting a bit old, but it is still working for the latest games. Is wfto that heavy on resources? According to the min specs I should be able to play this perfectly.

Things I have already tried:
First of all, I dont have integrated gfx.

I found an issue with it starting in dx9 instead of dx11. Managed to fix that but it basically made it a bit worse.
Also tried dx12 but no joy.
Re-installed my drivers (and drivers only) after a fresh uninstall with ddu.
Disabled my OC on my rig, but had no effect whatsoever.


Capture.PNG
output_log.txt

Game Version:
Steam Public
Platform:
Windows
Pending Customer

Hey Menta,


It sounds like you computer might just be struggling to run the game, it is pretty heavy on CPU usage. You should be able to run the Main Menu without much issue though.


Could you take a video of the lag you are experiencing? It might shine some light on what is causing it.

Right, you can close this ticket. After a full day of troubleshooting, it seems my pci-e slot where my gpu was slotted in had some failures. Switching my gpu to another free pci-e slot fixed it. Unexpected but glad to have it working.
Thank you for the support anyway though! :)

Completed

Glad to hear you're up and running, now go forth and build what your dark heart desires


(get straight back to us if you have any other issues)