+1
Completed

mutator not loading, not saving after first map try (1st game fresh after editor)

Carlos Michal Martinez Rico 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 12

I made this map http://steamcommunity.com/sharedfiles/filedetails/?id=823015109 in the editor, ajusted the Mutators according my specs and tried it on a skirmish against AI, when re-launching the map later I discovered that the Mutators were reset to default, re-entered the editor and was not able to load a Mutator profile, could not save it or change it eighter, when i made the changes manually or tried to save it as another profile, after the confirm buttom it resets back to the default profile.

Same when loading the map on multi, press load mutator profile, resets to default after confirm.

Any help with this will be welcomed. Thank you for a great game !



Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED

straight to the point, effective and applies solutions as soon as possible :) cannot be better really, only if you guys would give something back... oh wait... you do! content :)) so yeah exelence

Satisfaction mark by Carlos Michal Martinez Rico 2 years ago

Hi there ! Found a solution (it may help show the problem). When I open the map and load the mutator i need to edit any setting (example disable a room) and re-enable it again. Then it shows the (I am sure i want to apply changes) popup. Otherwise it just closes settings and does not load them. So it may be a UI thing or not a problem at all, but It may confuse some people (did confuse me).

Anyway thanks ! Gonna play now.

Hello Carlos,

I am not 100% sure if I understand the issue correctly.

So you said you changed mutators for your custom map and you confirmed your changes by clicking the "confirm" button.
Then you tested the mutators in a skirmish game and they did work,
but when you loaded the map again in the map editor all your mutator changes were lost?

Is this the problem or did I misunderstand?
Could you quickly make us an exact list of steps to reproduce the issue?

Hi there ! :)

1. I created map in editor
2. I created a particular set of mutators
3. Mutators had to create a mutator profile and press accept for the profile to apply in the editor
4. Exit editor and went for skirmish
5. Skirmish map did not load mutators by itself
6. Mutator profile load did not work, reseted itself back to default
7. Had to edit the profile (example just clicked from a researched room to unlocked and back) for the game to save the profile
8. After saving the profile and pressing accept the mutator loaded (visible in the map preview window on the right)

Till i figured this out it really made my day, would be great if a tooltip told me that or if it would change the mutator by itself after edit.

Also noticed when i edit a map in editor (that is published already by me) and I edit the mutators, the map on the steam workshop retains the old mutator profile. Did not happened all the time or I may not have find out why it happened yet. Anyway just a tip.

Tell me if you guys need anything. and Thank You :)





Hello again,

thanks for your fast response and for helping to improve the game.

I did try all the steps you mentioned, but couldn't find any unintended behaviour.
But maybe something is confusing for you which seems clear for myself.

Let me comment on a few things you said above:


>> 3. Mutators had to create a mutator profile and press accept for the profile to apply in the editor

It is only needed to "save" a mutator preset, if you want to reuse the same mutator settings for multiple maps.
When saving a preset it takes just a snapshot of the current settings independent if they are applied or not.
When a mutator preset is saved it is not applied to the map unless confirmed.
So no matter if or if you not save a preset the current mutator settings are only applied when the "confirm" button is clicked.
After this the mutators are stored persistently with the map and should always apply when the map is played (except they are overriden in the game lobby eg. Skirmish).
When mutator changes are not confirmed they are always discarded.
And when you open the same map again in the map editor it should show the same mutator settings as you applied with "confirm" before.
Did you really confirmed the mutator changes before closing the map editor?


>> 6. Mutator profile load did not work, reseted itself back to default
>> 7. Had to edit the profile (example just clicked from a researched room to unlocked and back) for the game to save the profile
>> 8. After saving the profile and pressing accept the mutator loaded (visible in the map preview window on the right)

When you confirm mutator changes in any game lobby eg. Skirmish, it will only apply the mutator for the current game, but it won't store it persistently with the map.
The only way to apply mutator changes permanently for a map, is to confirm them in the map editor.


>> Also noticed when i edit a map in editor (that is published already by me) and I edit the mutators, the map on the steam workshop retains the old mutator profile. Did not happened all the time or I may not have find out why it happened yet. Anyway just a tip.


This seems also intended, the changes made on a map are only uploaded to Steam Workshop,
when you Publish the map again AND Select any publish type which is NOT "Local", otherwise only you local copy of the map will have the newest changes while your Steam Workshop remains unchanged.

>> Till i figured this out it really made my day, would be great if a tooltip told me that or if it would change the mutator by itself after edit.

I still do not understand what the confusion about this exactly is.
Thought it would be clear, that non-confirmed changes are always discarded and a dialogue tells that they are discarded.
What could we make better to avoid confusion?
Or do you play in a different language than English, so it could be any bad translation which is causing confusion with mutator settings?

Update:
I did find one particular issue.
When you load a mutator in a game lobby (eg. Skirmish) and confirm it without doing any modifications after loading, it is not applied.

I fixed this bug now for next minor patch.

Was it this issue you did run into and is your entire report resolved by fixing this particular issue or is there another issue we should take a look at?

I think you answered it all pretty much for me thank you!
It is possible I was tired and missed the basic points.

What is actual :

"One more thing, when playing on multiplayer with a new downloaded map if the other player does not have the map it downloads it from him, with a crash after loading the match. So the other player needs to restart the whole game after the crash and then the map starts normaly.

Tested it on LAN options."

If my wife downloads the map first on workshop it works. So I think is a local sharing thing.

There was also an animation anomaly while we played the match. Corpses tied together and spinning like there was no tomorrow. Ill make screenshot if I can this week.

Also there was this crash after we played for 50 minutes but the map was huge and player made (so tooons of creatures and stuff) at full hd and graphics on max, I am sure it was a problem with me running out of ram or something.

I was editing the post now (my english is terrible when I do not give it a while to fix it)

Hi there ! :)

1. I created map in the editor.
2. I created a particular set of mutators after i finished the map.
3. Mutators did save at first time. I did create a mutator profile and pressed accept for the profile to be applied to the map.
4. I Exited the editor and went for try on the skirmish.
5. Skirmish map did not load mutators by itself. So I exited.
6. The problem I found was that the mutators profile auto-load for the map did not work, It reseted itself back to default. So I entered the mutator profile editor and tried to change it manualy, then I presed accept. Did not work. Tried third time with save profile before exiting the mutator editor. Did work.
7. So I had to edit the profile (example just clicked from a researched room to unlocked and back) for the game to save the profile.
8. After editing and re-saving the updated profile and pressing accept at the end the mutator loaded (visible in the map preview window on the right)

Till i figured this out it really made my day, would be great if a tooltip told me that or if it would change the mutator by itself after edit.

Also noticed when i edit a map in editor (that is published already on workshop by me) and I edit the mutators, the map on the steam workshop retains the old mutator profile. I had to manualy delete the map on workshop and re-upload the whole thing.

Also I noticed I had to wait for the steam to re-upload and re-download it again. It is logical but also did not know that right away.

One more thing, when playing on multiplayer with a new downloaded map if the other player does not have the map it downloads it from him, with a crash after loading. So the other player needs to restart the whole game after the crash and then the map starts normaly.

Tested it on LAN options.

Tell me if you guys need anything. and Thank You :)

Hey again,

I am glad that we got the mutator issue sorted and you can now enjoy using mutators on maps.

For the other issues you mentioned: Would you mind to create new tickets?

For us it is the simplest to keep track about one particular issue per report which corresponds to one internal bug ticket to resolve.
This way we can prioritize, manage, assign and resolve separate issues individually.
Please include your output_log from the session where you encountered the issue in the tickets.
(How to do this is explained here http://brightrockgames.userecho.com/topics/118-how-to-submit-a-bug-ticket/)

Thanks for helping to make things better! :)

Completed - Next Patch

No problem will get to it tonight :)