0
Completed

WFTOGame.exe has stopped working when quit

policeofficer110 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 10 months ago 25

When I pressed the QUIT button, WFTOGame.exe has stopped working.

The output_log says that NullReferenceException has occured.



output_log.zip


Thank you and best regards.
Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by policeofficer110 2 years ago
Under Review

This should not happening just because of a single NullReferenceException.
How often did you encounter this problem so far?

I have encountered this error every day since the game was upgraded to v1.5.

( or, since I created community translation. )


I am encountered today as well.
1. I started the game.
2. I visited my home realm.
3. After 1 minute, I returned to the main menu.
4. I pressed the QUIT button.
5. WFTOGame.exe has stopped working.

output_log1.zip

output_log2.zip

savedata.zip


Thank you and best regards.

it happened to me when I had problems with the translation files.


http://brightrockgames.userecho.com/topics/1638-argument-out-of-range-at-start/


once solved the problem, it works fine

I see an error at the end of the logs we did fix today.
We will upload another hotfix build (v1.5.0f9) very soon which should hopefully have this fixed.
Let us know if not.

I'm glad to hear that. I sincerely appreciate your swift action. Thank you.

Unfortunately, v1.5.0.f10 still have this problem.



output_log3.zip


Accepted

I thought it is now impossible that this error at the end is still unless I saw there is a condition trying to prevent this above in code which is actually causing this error.
OK let us try to sort this once more.

No. v1.5.0f12 still have this problem.

But, the output_log is different from what I have ever had.

And, this problem occurred without my Community Translation.

output_log_v150f12.zip

I can confirm that I am having this issue too. Here is a recording of it, and my output log.

2016-12-18 18-24-51.mp4

output_log.7z

Seems the error which you guys had is now fixed.
Now your logs look clean and I do not know what could be still causing this.
I fear again a Unity issue on certain systems, as it does not happen to me.

Can you try something for me?
Can you start cmd.exe and type regedit to open the registry editor.
Go to the folder
HKEY_CURRENT_USER / SOFTWARE / Subterranean Games / War for the Overworld
and delete all keys in right window which start with
"ScreenManager"
"UnityGraphicsQuality"
and
"UnitySelectMonitor"

then restart and quit the game.
Does it still do that?

Seems to be an issue other Unity games have as well.
Hope this gets addressed soon.

the problem is caused by the translation files.
editing the file with a free programs(libreoffice / openoffice) are created automatically columns and this causes the bug when you click on QUIT or when you enter the game menu.



try moving the translation files, without the community translation file the problem does not occur.


use google docs for edit files

I would at least not see how.
The translation files are parsed on game load and only again if set in the options and in this process any additional columns or anything which is not part of the key-text-pairs gets ignored.
From then the files are untouched and their keys are just stored in a dictionary in memory.
So there is no reason that this could have any impact at least theoretically.

+1

I will try to reproduce the bug tomorrow

Unfortunately, deleting the registry did not improve this problem.

output_log.zip



It might be a Unity thing and they released a new hotfix themselves which is supposed to resolve crashes.
https://unity3d.com/unity/qa/patch-releases/5.3.4p5
"Game Performance: Fixed a potential crash on player exit if Game Performance Service is enabled."
We have this service on and thus this fix note matches our problem here exactly.

We will update to this Unity version and will see if this stops the annoying crashes on quit.

Going to mark this as done for now - The next patch that comes out should resolve this problem. If not, let us know and we'll reopen it to investigate further.

OK. When the next patch comes out, I will report the result.

I confirmed that this problem was fixed. This error does not occur anymore in the version 1.5.0f13 :)

Just encountered same problem, WFTOGame.exe has stopped working upon closing the game.. just installed from Steam.

Hello Carlo,


The current lead ticket for this item is http://brightrockgames.userecho.com/forums/1-war-for-the-overworld/topics/2896-game-crashes-on-quit-from-main-menu/ this is a known issue that only appears on some systems for reasons unknown to us. It appears to be occuring on an AMD Driver call during the shutdown process, this means the code from our game has successfully handed off to Unity to shut the game down but for some reason the AMD Drivers fail to respond as expected. There's no cause for alarm with this issue, it's merely an annoyance but we are monitoring and would welcome a DXDiag report from you and any further information you can provide on your system. :)


Cheers,


Lee