0
Declined - Not a Bug

Game keeps crashing

Thomas 2 years ago • updated 2 years ago 7

I've had continuos crashes on the tutorial and first mission.

  • OS Windows
  • Version 10
  • 64bit
    • Ram 16GB
    • CPU 6700k i7
    • GPU 980TI

Here are the error logs:

crash.dmp error.log output_log.txt

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED

Fast response and very willing to help.

Satisfaction mark by Thomas 2 years ago
Under Review

Hey Thomas,
this sounds very unusual and I am sorry to hear you get such troubles.
One quick thing to try:
If you have wireless headphones try if by unplugging them it does not crash.
If so, then make sure they are set as default audio device and to stereo mode. (just one known issue)

If it is not this, can you take a look at
http://brightrockgames.userecho.com/forums/2-war-for-the-overworld-knowledge-base/categories/2-common-issues-solutions/topics/
and see if there is a solution for you?

Cheers

im currently using stereo speakers.

I've tried most of the solutions with no success.

Bummer, please try still the other solutions if you not yet did so.
The log reveals a crash deep in Unity internals (inside the game engine we use) which is hard to track down without their support.
Do you have other games based on Unity3d engine in your library which do work?

For sure try verifying your game files as stated in the second sub link from the link I posted before above as this often wipes out corruptions happened on downloading the game.


Also worth a try:
Case 2: Incorrect rendering mode (DX11 instead of DX9 loaded or vice versa)


If you have tried the above Case 1 solution but that has not worked and you are on a Windows system then you can try forcing WFTO to launch in DX9 mode or DX11 mode. To do this follow these instructions.



  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add "-force-d3d9" in this box (No quotation marks)
  4. If this fails and you have a DX11 compatible GPU then add "-force-d3d11" instead.
  5. If you are running Windows 10 or newer you can also try "-force-d3d12"

Do you use AVG Antivirus?
It is known to see the game sometimes as false positive threat and blocks it, so that the game does crash.
In this case you need to add an exception for the games executable.

Only if you tried all the solutions from the knowledge base read further.


Sometimes such crashes can be caused by a faulty winsocket configuration.
If so you could try this:
https://forum.unity3d.com/threads/unity-5-access-violation-crash-bug-reporter-problem.312024/#post-2130017
Your issue looks similar to this one on a different game:
http://www.tomshardware.co.uk/forum/id-2926006/access-violation-0xc0000005.html
You could try what is said there if nothing helps, but this would be no ideal solution.

Otherwise we need to assume there is a compatibility issue with Unity3d.
In this case a fix could take quite long and if you don't like to wait and just got the game you can always refund it on steam as long you are less than 2 hours into the game.

I hope any of this is helpful.

Sorry for such inconvenience, but I can assure you such problems are rare.

Thanks for getting back to me, i was using a 720p screen I then bought a 4k monitor so now run the game in 2K (highest setting). However I still had the same issue so I started playing round with the in game settings and I found turning v sync off solves the issue. I haven't seen a game crash since! Thanks, Tom.

Declined - Not a Bug

Hrm this sounds weird and should not happen.
For some people it is even the opposite: they get issues because V-Sync is off and FPS are too high.
Also what I did not saw first time is you run two GPUs.
Just wanted to mention that SLI mode can cause problems with our game and some people needed to run it on either card to work.

However I am glad you got it sorted and can play the game.
Thanks for keeping us updated! :)

Yeah it's an odd one. No I've only got the one gpu.