0
Completed

Extreme lag with Idle Workers

Xirath 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 6

I have been experiencing extreme lagg when playing and i recently noticed that it is related to workers on Idle. I tested with 16 workers on 4 goldshrines and about 40 units on the map and the game runs smothly, but as soon as i add 1 worker the game starts lagging like crazy and my fps goes from 60 to around 5 or 10.


I also loaded up a few saves were i was having bad lag and removed the idle workers and the lagg immediately stopped. I made a quick search on the forum but i did not find anything about this problem, please fix :)


Otherwise i love the game!

Game Version:
Steam Public
Platform:
Windows
GOOD, I'M SATISFIED
Satisfaction mark by Xirath 2 years ago
Pending Customer

Hi Xirath,


Thanks for the report, please include your output log, system specs and ideally a save file for us. See here, I'll raise this as a concern on Monday :)


How to: Submit a Bug Ticket

How to: Locate your save files


Cheers,


Lee

That was fast :)


Specs:

Windows 10, 64 bit

6 GB RAM

Intel i7 - 920

NVIDIA GTX970

Build v1.4.2f8 (Updated: September 5th 4:44PM GMT+1)


I loaded the map and then summoned a worker (in the enclosed space, just to make sure it would idle) and it started lagging, summoned some more and it became almost unplayable, removed the idle workers and everything ran smoothly again, it actually run smooth if you just pick up the workers so they don't idle.

output_log.txt


I think this is the save file, a bit confusing when they don't have the same name as when you save

wetwork_20160918174633

(Do you need this meta file aswell?)

wetwork_20160918174633.meta


Declined - Cannot Replicate

Ah I forgot to post back here but I wasn't able to replicate this on the internal build and the save file didn't seem to have an issue. There are some pathfinding tweaks in the upcoming hotfix. When that's out give it another try and let us know if you're still suffering form the issue.