0
Completed

Black screen on startup

Infidelus 2 years ago • updated by Lee "Noontide" Moon (Community Manager) 2 years ago 42

Having been a Windows user for 20+ years, I'm now trying to convert to Linux. As such, I've installed Linux Mint 18 and the Linux version of Steam, but every time I try to launch WFTO I get a black screen and nothing else. Alt+F4 closes it (in proper Windows style).


The current version of WFTO is 1.4.2. If I go into Steam's Beta's section for WFTO and choose previousbuild (in this case 1.3.2) or the publictestbranch (v1.4.0 hotfix testing), the game launches without issue.

Game Version:
Steam Public
Platform:
Linux
GOOD, I'M SATISFIED

The team helped as much as they could, even when I got a bit frustrated with them for seeming lack of helpful updates on a Linux issue.

Satisfaction mark by Infidelus 2 years ago
Pending Customer

It is highly likely due to bad GPU drivers in Linux. Ensure you've got the most up to date drivers. You may need to do some research into which drivers work best for your configuration due to how fragmented Linux is with GPU drivers.

Unfortunately as I'm using an AMD Radeo 7850 card, there are no newer drivers for Linux. Also, the fact that the publictest and previousbuild versions both work seems to point to something unrelated to graphics drivers.

Can you please provide the Player.log for review?

Scott,


No problem. Please see attached


Player.log.zip

Hrm it looks like something to do with Gtk (The UI system Linux uses) or the theme it uses:

/usr/share/themes/Mint-Y/gtk-2.0/main.rc:1084: error: unexpected identifier `direction', expected character `}'


A quick google shows that it is a fairly common issue with Steam games. I can only assume that your UI theme doesn't work with the 3D engine we're using (Unity3D) for the specific version we're on. By chance, we're actually going to be pushing out a hotfix with a new version of Unity3D in a few days. So you could wait for that, or look into the above error and your theming system in the meantime.


Let me know how you get on, and I'll let our Community Manager know of this thread and to get in touch with you when we push the hotfix live.

Thanks Scott,


I'll have a look and see if there's anything I can do from this end (although I'm still learning Linux so won't get my hopes too high :)). In the meantime I look forward to the patch to see if that resolves the issue.

Accepted

Moving this to Accepted in my queue to remind me. Just to give you a heads up, we've had trouble pushing the hotfix due to an unusual issue uploading our builds to Steam.

Hi Lee & Scott,


Any news on a fix for the above yet?

Ah yes should have been rolled out a little while ago. 1.4.2f8 is the latest public version and the reports we had were extremely positive for fixes.


Give it a go and let us know how it went.

Hi Lee,


Thanks for the quick response. I'm still getting a black screen when I launch the game. Build ID is 1326908 according to Steam.

I feel like I'm pestering, but it's been about 2 months now since I was last able to play WFTO. Any updates on a fix for the black screen issue?

Hi,


After our latest patch we have been able to resolve all linux issues that we'd identified as broken on our end. Unfortunately it really does look like an issue with your configuration of linux. I have contacted our support contacts for one of our middleware partners at it may have to do with them and they may have a solution available for you.


Give them a couple of days to get back to us.


Cheers.

Thanks Scott,


I'm not sure how I'm *misconfiguring* my install. I haven't done anything special in my configuration, and as WFTO was working before you patched it, I'm not sure how it's an issue at my end.


For info, since my original post I've upgraded my graphics card to an Nvidia GTX 970 and am using their proprietary drivers (currently 361.42) however this has made no difference. I've also reinstalled Mint since getting the new card.

You may want to look into why the following modules aren't loading in your theme engine:


Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"
(exe:2097): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Mint-Y/gtk-2.0/main.rc:1084: error: unexpected identifier `direction', expected character `}'

A quick Google should identify some steps you can take based on your arch.

Thanks again Scott,


I'm happy to see what Google has to say about the errors you've mentioned but my point, which I mentioned in my original post and which I am obviously failing to get across, is WTFO was working perfectly well before you updated the game.


Version 1.3.2 launched without issue, so clearly something has changed in the WTFO code to stop it working on my system which, with the exception of the new graphics card last month, hasn't changed at all. The only thing that's changed is the update to your game. Unfortunately I can't roll back to 1.3.2 as it's no longer available in Steam as far as I can see.

+1

You're not failing to get your point across, it is unfortunately just not something we can take action with - We upgraded a number of subsystems within the game as part of the more recent patches and many of those subsystems are closed-source middleware. IE we don't have a real view into what has changed and cannot dig into them if there are problems.


Almost universally the upgrades helped solve many of the outstanding bugs and issues our users have had, which was the point.


It sucks that the upgrade appears to have stopped working with your configuration of Linux, it really does. We actively try to help every single person who comes here. But we cannot downgrade subsystems for you to try to solve the problem - It'll honestly just be too hard and time consuming for everyone.


The blunt truth here is that your version and/or configuration of Linux doesn't support our latest version of the game, furthermore it looks very much like a broken or old UI theme engine on your end.


I'd be more than happy to try to help you fix this, but you need to accept that you do now need to put some time into solving the problem on your end.

Hi Scott,

I've had a quick search on Google for the errors you've mentioned.
Gtk-Message: Failed to load module "gail"
Gtk-Message: Failed to load module "atk-bridge"

These are already installed according to apt

sudo apt install libatk-adaptor libgail-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libatk-adaptor is already the newest version (2.18.1-2ubuntu1).
libgail-common is already the newest version (2.24.30-1ubuntu1).
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.

http://askubuntu.com/questions/548557/how-to-install-gail-and-atk-bridge


exe:2097): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
Again, apt says these are already installed if I'm looking at the right page
sudo apt install gnome-themes-standard
Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-themes-standard is already the newest version (3.18.0-2ubuntu1).
0 to upgrade, 0 to newly install, 0 to remove and 2 not to upgrade.
/usr/share/themes/Mint-Y/gtk-2.0/main.rc:1084: error: unexpected identifier `direction', expected character `}'

I'm not using the Mint-Y theme at present and haven't since I reinstalled, so that message should be obsolete.

Hrm okay. Couple of questions and a solution:

  1. Do you run any other Steam-based games successfully at the moment?
  2. Do you have a non-english configuration at all?
  3. What output do you get when you enter locale into the console?

I'm seeing reports that it may be a locale issue. Try going through the last few posts in another Linux bug report starting here: http://brightrockgames.userecho.com/topics/1357-linux-black-screen-then-crash/#comment-5876


Additionally, you may try manually setting the locale prior to launching the game from the console as described here.

Hi Scott,


Yes, the following are all installed and work without issue:


Cities: Skylines
Dust: An Elysian Tail
Flockers
Planetary Annihilation
Prison Architect
World of Goo
Worms Clan Wars

I also have a bunch of others that aren't installed at the moment.

locale
LANG=en_GB.UTF-8
LANGUAGE=
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
I'm in the UK, so the above locale settings look correct.


There is indication that the lack of a value at `LC_ALL` is a problem. Try ensuring you close steam and the game and run it via the commandline with `LC_ALL=C steam`.

Well that certainly had an effect.


The WFTO loading screen appeared, got 3/4 of the way through the loading bar, then it crashed out, and the Steam application restarted.

Interesting. Can you please upload a new player.log from that session?

and the Steam application restarted.

What do you mean by this precisely? The game quit (no error), then Steam appeared to reload (login, etc)?

Yep, that's pretty much exactly it.


After WTFO dumped out, I was back at a terminal window (no errors), then Steam logged me back in again.

mmm. The only oddity I can see at the moment is this missing lib:


Fallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/winmm.dllFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/libwinmm.dll.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./winmm.dllFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./libwinmm.dll.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/winmm.dllFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/winmmFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/libwinmm.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./winmmFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./libwinmm.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/winmmFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/libwinmm.dllFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/libwinmm.dll.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./libwinmm.dllFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/./libwinmm.dll.soFallback handler could not load library /mnt/games/Steam Linux/steamapps/common/War For The Overworld/WFTOGame_Data/Mono/x86_64/libwinmm.dll

However I've never seen this nor can I find anything interesting out on the Google. I did notice you appear to have an xbox controller plugged in? This might sound odd, but could you try unplugging it prior to loading the game?

Hi Scott,


Unplugging the XBox controller made no difference, apart to my back as I had to crawl around to get to where it's plugged in :)

Looking at a linux machine here, I thought maybe your locale is still broken as the LANGUAGE env var is missing too, but I tried removing it and the game still ran no problems.


I may have to build a bebug build of the game for you next week to continue, as I don't have enough information to take next steps.

Hello Infidelus,
For me it looks like a potential Steamworks problem (https://partner.steamgames.com/).
Do you have other games which use Steamworks?
Do they work?
I wonder as well if Steamworks fails on its own DRM check because it can not connect to Steam Server. (which makes it quit the application and try to restart it with Steam for a second attempt).
So it would be worth looking if the network setup is correct and Steam ports are open.

  • ** (steam:4268): WARNING **: Unknown device type 14
  • ** (steam:4268): WARNING **: Could not create object for /org/freedesktop/NetworkManager/Devices/1: unknown object type

I/We have not much Linux experience but I found logs with similar issues around the web and maybe one of these links give pointers:
https://github.com/ValveSoftware/steam-for-linux/issues/3959
https://bbs.archlinux.org/viewtopic.php?id=208296
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1438003

Hi Scott,


I can't see any other games I've got that are available in Linux that use Steamworks, but I'm only looking at the homepage for the games to see if they mention it as it's not something I know anything about.


There's nothing special in my network configuration. RJ45 from PC to switch and switch to router. Every other game that requires network connectivity works, and I've just logged into my Windows partition and installed and launched WFTO there, so that seems to rule any blocked port problems.

Unfortunately we do not know exactly why you get a black screen and it can impossibly be caused by our own code.
But we use Unity3d, Steam/Steamworks and Coherent UI middleware and one of those is for some reason incompatible with your system configuration.
Thus I think fixing the system errors you got in the Player.log might resolve the issue (hopefully).
Unfortunately we are all no real Linux experts, we just know the game works for the majority of Linux users.
Maybe you can find a fix in the links I posted above?

Hi Stefan,


Apologies for calling you Scott in the previous message.


I have to say I'm a bit disappointed. You say you support Linux natively, but when push comes to shove you don't seem willing to put much effort in and excuse yourself saying you don't know much about Linux. I don't know much about Linux either in the grand scale of things, but I'm always willing to try and learn, as I am with troubleshooting what's wrong with your game on my install.


I can't do much though if you're not willing to pursue it. *The majority of Linux users* clearly isn't all Linux users, which means you have others that can't get the game to work either.


As I've said twice now, the game worked perfectly until you released an update, so blaming my configuration seems to be rather a cop-out answer. You've changed something significant that's broken the game for me, so the least you (collectively) could do is put some effort in to work out what you've changed that could be the root cause.


I'm not saying it's not my configuration, but being as I've reinstalled and not tweaked anything (especially network settings) and as it was working before you forced a patch on me, I'd say the ball's in your court.


I'm quite happy to try a debug build that Scott mentioned a couple of posts ago if it'll help find the problem, whether it's my install or your game update.

I'm not sure what you consider to be "putting in some effort" if almost a week of back and forth between 2/3rds of the entire code team and yourself doesn't count.

Have you tried reverting to the previous build (using the previous build beta branch), and seeing if you still have the issue on that version?


To rollback follow these instructions:

  1. Right click your War for the Overworld entry in your steam library and select properties
  2. Select the Betas tab
  3. Click the drop-down box and select "Previousbuild - Previous Build (v1.4.1)
  4. Click OK and allow your game to update
  5. Ensure that v1.4.1 is displayed as version number on main menu

If the issue doesn't occur in the previous build, then a player log from that version of the game might allow the coders to look for any differences between the 2 logs.

Hello Andrew,


Yes, I have had responses from the team over the last week, preceded by nearly two months of nothing as my request seemed to get lost in the ether and I only started getting responses again because I made a new comment.


To answer your question, yes I have tried the previousbuild, and I've just tried it again after deleting local content, and no it doesn't work.


As I said in my original post, the last build that did work was the v1.4.0 hotfix testing build. Everything since then has been broken.

OK, I take it all back and apologise unreservedly.


Ubuntu have just pushed out a bunch of patches today, one of with is for the network manager. Now I can't say for sure it's that particular patch as there were 5 updates including a Linux kernel update, but based on previous posts it does seem rather likely as the game now launches and seems to run fine from my very quick test.


I'd still like to know why the game worked fine before the 1.4.1 update, but it's working now so I'm happy for this to be marked as resolved.


I shall now go and stand in a corner.


[Edit]

I have just been struck by a blinding flash of light and I now know exactly what's broken the game, and it's not network manager.


If I try to install a kernel update, I have to uninstall my antivirus as it refuses to complete the kernel install when it's enabled. Instead the update just sits there 1/2 way through and won't finish.


Because I just did a kernel update in today's patches, that's exactly what I did, and I didn't reinstall the antivirus before I tested WFTO. I've just installed the antivirus again and lo and behold the game doesn't work anymore.


I'm sure you're dying to know which antivirus it is, and I'm really disappointed in them for this as I've always found them to be one of the better ones. The culprit is:


ESET NOD32 Antivirus


:(

+1
Completed

haha. Thanks for the frank reply. We'll make sure to add it to our list of things to ask future users with similar issues. :)

Just a quick further update.


I raised a ticket with ESET about this which they responded to very quickly, and while they say there's no fix for the current version of NOD32 for Linux (4.0.82), you can work around it by editing the /etc/ld.so.preload file and commenting out the line referencing libesets_pac.so. It's the only line in the file on my install, and I've just tested it and it works (no need to reboot after editing it).


Don't forget to uncomment it after though as it does affect real time file system protection.

Completed - Next Patch