0
Pending Customer
Michela 2 weeks ago • updated by Lee "Noontide" Moon (Community Manager) 2 weeks ago 2

I bought the game yesterday and this morning I installed it on my computer, all set up to that point, but after I click on the icon to start playing, I get into the game very slowly without giving me the chance to choose The various options. It enters directly into the dungeon and then there I go no further, it does not give me the chance to click on anything, it locks and I'm forced to close it by windows. So I uninstalled and shredded several times without results.
My operating system and windows 10 home, 64 bit system, AMD 4core A10-7400P CPU, up to 3.4 GHz. Processor: AMD A10-7400P Radeon R6, 10 Compute Cores 4C + 6G 2.50 Ghz. Do you know me what to do? Otherwise, I require the repayment of the game at extreme speed.
Thanks so much

Game Version:
Platform:

Game Version: 1.6.3

Platform: Windows 10

Pending Customer

Hi Michela,


I've moved your topic to the bug tracker from our general help and support forum.


Sorry to hear about your issues with launching the game. We'd love to help you resolve the issue, from the description of your issue it sounds like the UI is not loading once you get into the game? So you see the green Dungeon Core but no other options on the screen? If that's the case there's a chance that one of these workarounds will help you: 


Article: Missing, Invisible or Laggy UI


If you'd like to give some of those a go and let us know how you get on we'll be able to advise further from there. It'd also be great if you could provide an output log by following the relevant instructions from this thread: How to: Submit a Bug Ticket we might be able to identify exactly what is happening to cause your UI to fail.


From your system specs I can see you have an AMD CPU with inbuilt Radeon Graphics, if you do not have a discrete graphics card in your system this may also be the cause of your issue. Unfortunately the Graphics processing power of your CPUs inbuilt graphics benchmarks at an average of 673 score on 3D Mark tests. Our game requires a minimum of 1500 as outlined in our System Requirements. Although this does not mean tthe game is unable to run we would expect your experience to be well well below optimal.


If this is the case than my advice would be to refund the game at the most convenient opportunity. If you'd like me to advise how to do that you can email me a copy of your purchase receipt and details of where you purchased the game from direct to support@brightrockgames.com and I'll be able to help you further from there.


I'm truly sorry the game did not provide an adequate experience to you.


Lee